Applications or published desktops launched with the HTML5 client fail to start

Applications or published desktops launched with the HTML5 client fail to start

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Article ID: CTX285164

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Updated On:

Description

  • Applications or published desktops launched with the HTML5 client fail to start.
  • Users see "Error: Citrix Workspace app cannot launch app"
  • The user may briefly see the 'Connection Interrupted' message displayed immediately at the beginning of the session.
  
  • Applications or published desktops launched with Citrix Workspace App are successful.
  • Administrators troubleshooting the issue may detect that the server suffered a BSOD and restarted.
  • Administrators able to collect a memory dump will find Bugcheck Analysis will mention "Probably caused by : icardd.dll"

 
 
 

Resolution

The best solution is to upgrade the VDA to Citrix Virtual Apps and Desktops version 2006 or greater. 
If your VDA is Windows 2012 R2, please open a case with Citrix Technical support and request the private fix that can be installed on Citrix Virtual Apps and Desktops version 1912 CU1. Reference for this is CVADHELP-16160. 

Problem Cause

This issue was triggered by a change in the Citrix HTML5 client.