Microphone device at Linux endpoint is not redirected to HDX Session

Microphone device at Linux endpoint is not redirected to HDX Session

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Article ID: CTX282505

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Updated On:

Description

When using Linux endpoint  to connect HDX session, user might find that client-side microphone device is not redirected to HDX Session and media applications running in the HDX Session also cannot detect any microphone device, e.g. in Windows Control Panel > Sound > "Recording" tab, there is no any microphone device present.

Resolution

Please follow below steps to enable HDX Audio Input in Workspace app for Linux,
  1. Open "/home/#username#/.ICAClient/wfclient.ini" file and add below line under [WFClient] section, and save the change.
    • AllowAudioInput=True
  2. Restart Workspace app for Linux.

Problem Cause

HDX Audio Input is not enabled in Workspace app for Linux

Issue/Introduction

The article describes a microphone redirection issue because of HDX Audio Input is not enabled at Workspace app for Linux.