"Cannot Complete Your Request" error observed when user tries to launch Storefront's web shortcut

"Cannot Complete Your Request" error observed when user tries to launch Storefront's web shortcut

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Article ID: CTX282271

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Updated On:

Description

User unable to launch an application or desktop when using a Web shortcut. The following error is observed.

Example of Web Shortcul URL:
https://storefront.domain,com/Citrix/StoreWeb/#/launch/Notepad/xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

In this scenario user is attempting to launch Notepad



Once the user enters credentials they will encounter the error "Cannot Complete Your Request"



 

Resolution

  • Event Logs will not show any Errors related to this behavior
  • Wireshark Trace will not provide useful information about this behavior either
  • To remedy this problem go to Storefront's Management Console
  • Click on manage Receiver for Websites for the Store you are attempting to fix experiencing this behavior
  • Click on the "Configure" button
  • Select "Website Shortcuts" option on the left
  • The "Add the URLs for Website which will host resource shortcuts" is EMPTY. The admin must enter the Storefront's URL address here by clicking on "ADD"
Example Below:

  • this will allow for the Applications or Desktops to be able to launch using Website shortcuts

Example:


Problem Cause

Step
  • Add the URLs for website which will host resource shortcuts in Storefront Console has to be populated as explained above and not left blank.

Issue/Introduction

"Cannot Complete Your Request" error observed when user tries to launch Storefront's web shortcut