Published apps not launching for some users when connecting through VPN, no errors

Published apps not launching for some users when connecting through VPN, no errors

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Article ID: CTX280797

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Updated On:

Description

•    Users connect to the company’s network using Citrix Gateway VPN
•    When launching a published app, the progress popup shows up and disappears seconds later, nothing else shows app, no errors
•    Receiver Connection center shows a connection with the VDA but no app launched
•    VDA shows the user session running sub processes in Task Manager
•    Studio and Director show an active session for the user
•    Same user is able to launch Desktop sessions using the same endpoint at home
•    Same user is able to launch the same apps if using a different endpoint from a different location
•    Issue impacting some users, not all of them
 

Resolution

Disabled HDX Adaptive Transport policy in Studio resolved the issue

Problem Cause

EDT conflicting wiht local user's network configuration, or UDP ports being blocked at ISP level.

Additional Information

How to Configure HDX Enlightened Data Transport Protocol
https://support.citrix.com/article/CTX220732