Citrix Cloud Director console reports “Licensing Error” against Microsoft RDS Licensing.

Citrix Cloud Director console reports “Licensing Error” against Microsoft RDS Licensing.

book

Article ID: CTX279891

calendar_today

Updated On:

Description

Citrix Cloud Director, which can be accessed from the Cloud Console monitor tab reports “Licensing Error” against Microsoft RDS Licensing in the Machine Details Pane when you check a users session details. However, there are no other symptoms.
Sessions still start and the RDS license server itself reports no errors.

Resolution

  1. Access a VDA and open regedit
  2. Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\Licensing Core\LicensingMode
  3. Look at the value, it should be 2 for ‘per device’ and 4 for ‘per user’ license type.
  4. Change the value to the correct license type.

Problem Cause

VDAs not update to reflect RDS registry changes in newer Windows versions. 

Director is checks in: 

HKLM \ SYSTEM \ CurrentControlSet \ Control \ Terminal Server \ RCM \ Licensing Core \ LicensingMode

But it should be checking in: 

HKLM \ SOFTWARE \ Policies \ Microsoft \ Windows NT \ Terminal Services \ LicensingMode