Users are unable to see apps when logging into the Citrix Cloud when Citrix Gateway is the authentication method.
book
Article ID: CTX279691
calendar_today
Updated On:
Description
When users login to the Citrix Cloud for app enumeration, they do not see any apps. Currently you get a message saying that there are not available apps at this time.
If authentication is set to Active Directory within the Identity and Access Management/Authentication section of the Cloud Administration, the users are able to see their apps.
Resolution
Check Studio and ensure that users are not being given access using Domain Users. If so use a different group for app access and your users should see their apps.
Problem Cause
When LDAP pulls the memberof attribute, it is not going to reply back with the users "primary group". By default Active Directory designates the Domain Users group as primary.
When using Citrix Gateway for authentication to cloud, the login method will be LDAP and groups will be determined based on the LDAP attribute "memberof". As a result the cloud is unaware of the Domain Users group and apps are not seen.
When Active Directory is used, Citrix Cloud passes off your credentials to the Active Directory where all groups are seen.
On prem ADC is not an issue here because LDAP groups are determined only for session policy and SmartAccess whereas Storefront uses Active Directory to determine groups.
Was this article helpful?
thumb_up
Yes
thumb_down
No