Unable to add machines to machine catalog (Citrix Cloud)
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Article ID: CTX279688
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Updated On:
Description
Error Id: XDDS:3DE004AE
Exception: DesktopStudio_ErrorId : UnknownError Error Source : CitrixPVSService Sdk Error Message : A referral was returned from the server.
Sdk Error ID : Citrix.PVS.PowerShell.Commands.GetPvsADAccountCommand ErrorCategory : NotSpecified DesktopStudio_PowerShellHistory : AddPvsMachinesScript 8/4/2020 10:06:33 AM Clear-PvsConnection Set-PvsConnection2 -domain "mail" -password "System.Security.SecureString" -port 54321 -server "XX.XX.XX.XX" -user "XXXXX" -zone "XXXXX" Get-PvsVersion Get-SimplePvsCollection -collectionId @("######-XXXX-######-XXXX-######") Get-SimplePvsDevice -collectionId @("######-XXXX-######-XXXX-######") Get-SimplePvsADAccount -domain "XXXXXX" -name "XXXXXX" Get-SimplePvsADAccount : A referral was returned from the server.
Resolution
1. Confirm the Admin account is Farm Admin in PVS and Site Admin
2. Check if the issue is happening with new catalogs as well.
3. Check PVS Database : " dbo.device " for NULL entries
- Check if Domain Name, Domain Object SID, Domain controller Name and Domain time Created Fields are NULL
- Make a Note of the machines with NULL entries
- If YES, on the PVS console > Device Collection > Rt. click on Target and goto Active Directory > Delete Machine Account ( with Null Entries ) and Recreate the Machine Account
- Do the same for all machines with Null entries in the DB
- Try to Add machines to the catalog now.
Problem Cause
Null Entries in PVS DB (dbo.device table) for the following fields:
- Domain name
- Domain object SID
- Domain controller name
- and Domain time created fields
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