Elastic layers are disconnected and not accessible in session host

Elastic layers are disconnected and not accessible in session host

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Article ID: CTX279630

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Description

Environment before 20.5(2005) observed the Elastic layers were disconnected on the VDA abruptly and were not available for exiting user connections or for new users..

The below errors are seen though the layer(s) had been attached by a prior domain user.

--ulayersvc.log--

2020-03-23 13:23:02,140 WARN 15 LayerConfigService: Can't find the volume UDiskPD803AV0R2 @ \\?\Volume{000cebef-0000-0000-0000-100000000000}\.  It will be reattached on the next login.
2020-03-23 13:24:02,147 WARN 15 LayerConfigService: Can't find the volume UDiskPD8037V0R1 @ \\?\Volume{0001ddd7-0000-0000-0000-100000000000}\.  It will be reattached on the next login.
2020-03-23 13:24:02,149 WARN 15 LayerConfigService: Can't find the volume UDiskPD8035V0R1 @ \\?\Volume{000de223-0000-0000-0000-100000000000}\.  It will be reattached on the next login.
2020-03-23 13:30:02,165 WARN 7 LayerConfigService: Can't find the volume UDiskP3A8001V0R1 @ \\?\Volume{00068b43-0000-0000-0000-100000000000}\.  It will be reattached on the next login.
2020-03-23 13:40:02,174 WARN 14 LayerConfigService: Can't find the volume UDiskPD8033V0R1 @ \\?\Volume{00035958-0000-0000-0000-100000000000}\.  It will be reattached on the next login.
2020-03-23 13:40:02,177 WARN 14 LayerConfigService: Can't find the volume UDiskPD8038V0R2 @ \\?\Volume{00060cc0-0000-0000-0000-100000000000}\.  It will be reattached on the next login.
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Other symptoms are the EL disks appear with no sessions in the storage device monitoring tool(s). In one customers use the SOFS cluster file sessions were not present to the disks. Manually remounting the disk(s), to the session host fixes the application, disk access failures.


A similar error, seen below, may appear when a user attempts to launch an elastic app layer.

 

Resolution

By default, when the first user assigned an elastic layer logs on to their desktop, all elastic layers assigned to the user are mounted. Other users who log on to the machine hosting the layers use the same connection as the first user. The connection lasts for 10 hours after the first login, and then all elastic layers are disconnected. In a shift-based environment, users on the second shift would be impacted about two hours into the shift (or, 10 hours after the initial user logged on for the first shift).

If you are delivering elastic layers in a shift-based environment, you can change the default account under which all elastic layers run. Instead of running under the first user who logs in, you can change the default user for all elastic layers to the ulayer service, which runs under the local SYSTEM account. The SYSTEM account corresponds to the domain machine account of the machine that the ulayer service is running on when accessing the share. The file share containing your elastic layers requires read-only access, either for all users, or for each machine account.

To change the account for elastic layers to run under, create the registry DWORD value, and set it to 1:

HKEY_LOCAL_MACHINE\Software\Unidesk\Ulayer:AsSelfAppAttach to **1**

To revert back to running elastic layers under the first user to log in, set the registry DWORD value to 0:

HKEY_LOCAL_MACHINE\Software\Unidesk\Ulayer:AsSelfAppAttach to **0**

To remove the setting so that elastic layers can only run in the default mode, remove the DWORD value:

HKEY_LOCAL_MACHINE\Software\Unidesk\Ulayer:AsSelfAppAttach

 

Copied from our online documentation.

https://docs.citrix.com/en-us/citrix-app-layering/4/layer/assign-elastic-layers.html

The new setting was added in 2005.


Problem Cause

Per the design, the elastic layers were mounted with the first user account to login, not a system account.

Additional Information

https://docs.citrix.com/en-us/citrix-app-layering/4/layer/assign-elastic-layers.html#considerations