Blank/White page after upgrading Citrix ADC or Citrix Gateway.
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Article ID: CTX277650
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Updated On:
Description
After performing an upgrade, the Citrix Gateway login page or either the Citrx ADC or the Citrix Gateway GUI management page show blank/white page.
The issue can, sometimes, be observed even setting the Gateway custom theme to "default" before the upgrade.
Environment
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Resolution
Option 1:
If previously the "
httpd.conf" file was modified, as suggested in
https://support.citrix.com/article/CTX255947
- Ensure you have the local copy of the original /etc/httpd.conf
- Delete the /etc/httpd.conf
- Delete the /nsconfig/httpd.conf
- Copy your local copy of httpd.conf to /etc/httpd.conf and /nsconfig/httpd.conf You can also copy the file from a different Citrix ADC or Gateway running the same version and build.
- Reboot the appliance.
Option 2
If there is a Custom Login Theme globally bound as described in
https://docs.citrix.com/en-us/netscaler-gateway/12/vpn-user-config/custom-portal.html#a-note-on-older-portal-customizations
- Downgrade to the previous version
- On the Configuration tab, Navigate to Citrix Gateway > Global Settings.
- Click Change Global Settings.
- Click the Client Experience tab.
- Scroll to the bottom of the screen then select DEFAULT from the UI Theme list.
- Click OK.
- Proceed to upgrade again.
Refer to Citrix Documentation for detailed information on upgrades:
https://docs.citrix.com/en-us/citrix-adc/12-1/upgrade-downgrade-citrix-adc-appliance/troubleshooting.html
Problem Cause
Manual modification on any of the login theme files.
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