Citrix Storefront Presents Error "Internal Server Error 43531" When Users Attempt to Log In

Citrix Storefront Presents Error "Internal Server Error 43531" When Users Attempt to Log In

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Article ID: CTX275968

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Updated On:

Description

When an end user tries to login into Citrix Storefront url, the users will receive the error message "Internal Server Error 43531"
 

Resolution

  1. Local/domain administrator to remote (RDP/console) into the Citrix Storefront Server/Virtual Machine
  2. Open Microsoft Services (services.msc)
  3. Navigate to the Internet Information Services (W3WP)
  4. Make sure it is in a 'Running' State 
  5. If in case the "world wide web service" is in stopped state, to start it and test the login again

Problem Cause

If the Internet Information Services (W3WP)Service is not in a 'Running State' this message is expected, because it will not route to the correct IIS Container for the site.