Selecting Store/App in Secure Hub End User Receives Error: "You may need to contact you administrator to verify your sign-on credentials"
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Article ID: CTX273401
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Updated On:
Description
When the user taps on the Store/Apps the error displayed in the popup window reads "You may need to contact your administrator to verify your sign-on credentials".
On Android Devices you may receive the following error messages:
- "Citrix Secure Hub could not connect"
- "Could not connect. Check if the client certificate is correct and not revoked"
Resolution
Confirm TLS v1.2 is enabled in the Citrix Gateway VIP settings.
Problem Cause
Though there could be multiple reasons, we have found that the above error is displayed when TLS v1.2 is not enabled on the Citrix Gateway VIP. Please make sure you have the TLS v1.2 enabled and try again.
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