Unable to view Restricted emails in outlook when connected through Citrix Remote PC Access.

Unable to view Restricted emails in outlook when connected through Citrix Remote PC Access.

book

Article ID: CTX272389

calendar_today

Updated On:

Description

Unable to view Restricted emails in outlook when connected through Citrix Remote PC Access. Restricted content within Microsoft Office products will show a black screen region instead. 

Resolution

This issue is related to the use of the Citrix IDD graphics adapter which is used by default in RemotePC installations to provide generic GPU support. The Citrix Display Only adapter can be used as a workaround using the following Windows Registry Key:

Path: HKLM\Software\Citrix\Graphics
Key: AdapterMerits
Value: DWORD CitrixDoD = 3
 

Problem Cause

This is a known issue when using the Citrix IDD adapter with Citrix Virtual Desktops versions 1912 LTSR through 2006. The Citrix IDD adapter leverages the Microsoft Windows Desktop Duplication API (DDAPI) for screen capture, that blocks restricted content in Microsoft Office applications by design. 

 

Additional Information

Display adapter priority and monitor creation in Citrix sessions - CTX237608