PVS Provisioned VDA Experiences Poor Performance and Freezing

PVS Provisioned VDA Experiences Poor Performance and Freezing

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Article ID: CTX272353

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Description

A PVS provisioned VDA can experience poor performance and freezing when the Machine Creation Services Write Back Cache drivers (MCS IO) are present in the vDisk image. It is typical to have first identified a machine in this state by its unregistered VDA status. While trying to access the VM, it may or may not reply to ping, RDP, or attempts to login via the hypervisor console. A reboot immediately clears the condition, and the same VM may or may not experience the same problem immediately. The presence of the MCS IO drivers in a Citrix PVS provisioned image have also accounted for slow or failed attempts to fully boot an OS. The VDA experiencing this behavior can have more retries than other VDAs who are not affected during this time. The driver conflict may be exacerbated by an increase in the need to process disk IO.

Citrix identified the installation of this driver should not take place when the provisioning mechanism is PVS.  There are reports of these drivers being installed during a clean install or even subsequent installation of one or many Cumulative Updates in the 7.15 LTSR branch to version 1906.  Citrix has fully resolved this matter with the 1912 VDA software and the drivers will not be present when Citrix Provisioning is defined as the provisioning method. 

Any Target Device running the VDA software between versions 7.15 - 1906 should be checked for the presence of these drivers and be removed if found.  Access to any redirected Target Device event logs can show an excessive amount of disk specific errors including write latency & disk access.  A Target Device memory dump may be needed to explicitly identify root cause.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

To determine if the VDA has the MCS IO driver installed by the following:

  1. Check the registry of the affected VDA to see if the following Key exists:         
    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CtxMcsWbc
  2. Expand the CtxMcsWbc key
  3. In the right pane, check for the REG_DWORD  key “Start” with a value of “0”

If found in the PVS provisioned target, the next step is to uninstall the driver in a maintenance version vDisk with the following procedure:

In a maintenance version vDisk, identify the installation GUID for the Machine Identity Services Agent by:
  • Open Regedit
  • Navigate to HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall
  • Highlight each GUID on the left pane while looking for “Machine Identity Services Agent” in the DisplayName field on the right hand pane.
  • Once you have located the correct GUID copy the string.
  • From an elevated command prompt type: MsiExec.exe /X{GUID GOES HERE w/ Brackets}. Hit enter.
Follow the prompts to uninstall the component.

Note: This change will not take effect until a machine has booted from this updated image.


Problem Cause

The MCS IO drivers consume memory and cause driver contention and NTFS blocking.  This leads to the Target Device Write Cache drivers, cvhdmp.sys, inability to process disk IO.  
 

Additional Information

It is possible that during a VDA upgrade the drivers reinstall themselves and it is recommended to check for their presence until version 1912.

CTX125086 - How to Capture a Memory Dump from a Provisioned Target in VMware Environment