StoreFront - Citrix Subscriptions Store service not starting up on one storefront server in server group

StoreFront - Citrix Subscriptions Store service not starting up on one storefront server in server group

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Article ID: CTX272320

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Updated On:

Description

When launching a published application  an error message is randomly seen .
 "Your apps are not available at this time. Please try again in a few minutes or contact your help desk with this information: Cannot contact Storefront"

The issue is caused by subscription service store service not starting up on one of the 2 storefront servers

Error seen when starting service - : "The Citrix Subscriptions Store service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs".

If the service used the  Local system account then it will start.
However if  the Network service account is used service wil not start.

Resolution

Export the subscription data using PS on the working server.

https://docs.citrix.com/en-us/storefront/current-release/configure-manage-stores/manage-subscription-data.html

Then remove contents of folder C:\Windows\ServiceProfiles\NetworkService\AppData\Roaming\Citrix\SubscriptionsStore on both Storefront Servers,

The follow the steps in the section “Restoring Data on a StoreFront Server Group”

Stop the Subscriptions Store service on working Storefront server..
Restore the data on non-working server using the Restore-STFStoreSubscriptions cmdlet.
Restart the Subscriptions Store service on servers StoreFront2.
It will then receive a copy of the data from StoreFront1.

Problem Cause

Corruption in this folder  on non-working folder.
C:\Windows\ServiceProfiles\NetworkService\AppData\Roaming\Citrix\SubscriptionsStore