Citrix workspace app | Uninstallation of CWA breaks ICA session
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Article ID: CTX272297
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Updated On:
Description
- If we have VDAs with this order of installation (CWA installed first and then the VDA).
- Now when we try to uninstall or upgrade the CWA, some display drivers from the vda get removed, as a result the ICA session breaks and the only way to get it working again is to - reinstall the VDA (reboot, reconfiguration of the VDA does not help).
- Machine stays registered in Citrix studio and if we try to reconnect to it, it simply disappears in a few moments
- On the VDA we see the following event for the session failure “Citrix ICA could not configure Thinwire and switch to the remote ICA display. Rebooting the workstation or logging in at the console will fix this.
- CWA is uninstalled and checking the device manager shows –
- Citrix Display only adapter in grey state (with the description - Currently, this hardware device is not connected to the computer. (Code 45)
- And Citrix Indirect Display Adapter completely removed.
Resolution
- Do not uninstall receiver but rather upgrade to Citrix Workspace App using the following command line to avoid accidently removing VDA drivers:
CitrixWorkspaceApp.exe ADDLOCAL=ReceiverInside,ICA_Client,USB,DesktopViewer,Vd3d,AM,SSON,BrowserEngine,SELFSERVICE,WebHelper,AppProtection,AppProtectionAdvanced
(Note: the above "AppProtection*" are not mandatory. SSON is also not mandatory based on customer's requirement)
- If receiver is uninstalled first and the VDA drivers are removed, you must remove and reinstall the Virtual Desktop Agent to repair the installation.
The long term fix is now part of CWA for windows starting with version 2007 & 1912 LTSR CU1 onwards.An internal Citrix bug has been created under ref: CVADHELP-13764
Problem Cause
Uninstallation of CWA is removing the Citrix indirect display adapter which is breaking the ICA session.
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