CVAD1912 - Wfica32 crash pointing to vdcdm30n.dll

CVAD1912 - Wfica32 crash pointing to vdcdm30n.dll

book

Article ID: CTX272183

calendar_today

Updated On:

Description

When connecting from a client machine with CVAD 1912 LTSR installed, customers may notice that the ICA Connection stops at a White Screen with the message "Connecting". This problem is noticed with CWA 1911 and 1912 LTSR. Client side event logs indicate crash of wfica32 process.

Log Name:      Application
Source:        Application Error
Date:         xxxxxxxxxxx
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      PC
Description:
Faulting application name: WFICA32.EXE, version : 19.12.0.119, time stamp: xxxxxxxx

Faulting module name: VDCDM30N.DLL, version : 19.12.0.119, time stamp: xxxxxxxx
Exception code: 0xc0000005
Fault offset: 0x00016276
Faulting process id: xxxx

Faulting application start time: xxxxxxxxxxxx

Faulting application path: C:\PROGRA~2\CITRIX\ICACLI~1\WFICA32.EXE
Faulting module path: C:\PROGRA~2\CITRIX\ICACLI~1\VDMRVC.DLL

Resolution

Correcting the Default.ica file as follows resolved the problem (Deleted the " marks):

Old entry:
DisableDrives="A,B,D,E,F,G,H,I,J,K,L,M,N,O,P,Q,R,S,T,U,V,W,X,Y,Z"

New entry:
DisableDrives=A,B,D,E,F,G,H,I,J,K,L,M,N,O,P,Q,R,S,T,U,V,W,X,Y,Z

Problem Cause

Problem related to CDM configuration in the Default.ica file