Site aggregation fails with error "We couldn't find your site"
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Article ID: CTX272160
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Updated On:
Description
Below are the symptom:
- The site aggregation fails with error - "We couldn't find your site".
- The Proxy By-pass list is configured on the Citrix Cloud Connected with the FQDN of the On-prem Delivery Controller in All capital or Mixed case, like - DELIVERYCONTROLLER1.DOMAIN.COM or DELIVERYCONTROLLER1.domain.com or DeliveryController1.Domain.com.
- Proxy Servers are not configured to resolve internal FQDNs.
- The developer log collected from the browser while performing the operation reports below error:
502 Bad Gateway - DNS error (the host name of the page you are looking for does not exist)
- The same error can be observed in a Wireshark trace collected from the Citrix Cloud Connector while performing the Site Aggregation.
- In the Resource Monitor, under the network tab, expand the TCP Connections section and in there we can observe the Web Relay and Discovery service reaching out to the Proxy Server's IP.
Resolution
Currently, one of the below two workarounds are available:
- Edit and import the Proxy by-pass list to have all the entries in All lower case.
- Configure the Proxy Servers to resolve the internal FQDNs.
Citrix is aware of this problem and is currently working towards fixing this issue.
Problem Cause
This issue is seen because the Proxy logic in the Citrix Cloud Connector expects all the entries in Proxy By-Pass list in all lower case and hence fails to process the entire Proxy By-Pass list, if even one entry is in All Capital or Mixed case.
Due to this, the Web Relay agent services reach out to the Proxy Server to contact the XML Service running on the On-Prem delivery controller.
Since the Proxy servers are not configured to resolve the internal FQDNs, the above service is unable to resolve the Delivery controller addresses and hence the site aggregation fails.
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