Enable Local Host Cache with Citrix Cloud

Enable Local Host Cache with Citrix Cloud

book

Article ID: CTX272155

calendar_today

Updated On:

Description

During network outage, Local Host Cache (LHC) not toggling in Cloud environment

Resolution

Utilizing the Citrix Powershell SDK run the following:

For site-wide: 
Get-BrokerSite -Property ReuseMachinesWithoutShutdownInOutageAllowed, DefaultReuseMachinesWithoutShutdownInOutage



For select delivery groups:
Set-BrokerDesktopGroup -Name "name" -ReuseMachinesWithoutShutdownInOutage $true


For all delivery groups:
Get-BrokerDesktopGroup -Property DesktopGroupName, DesktopKind, SessionSupport, ReuseMachinesWithoutShutdownInOutage | where { ($_.DesktopKind -eq "Shared") -and ($_.SessionSupport -eq "SingleSession") }


Note:  Please review this setting from a security standpoint before enabling as these Desktops might contain data from the previous user session as VDAs have not been restarted.

Problem Cause

Default behavior is to have managed desktops VDAs placed into maintenance mode when an outage occurs. Please note that Local Host Cache is not supported with Citrix Cloud Workspaces and must be used with an on-prem Storefront.

Additional Information

https://docs.citrix.com/en-us/citrix-virtual-apps-desktops-service/manage-deployment/local-host-cache.html