Citrix Service Provider license server not reporting due to SSL error

Citrix Service Provider license server not reporting due to SSL error

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Article ID: CTX270919

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Updated On:

Description

After an extended maintenance period in March 2020, some Citrix License Servers that were successfully reporting into the License Usage Insights Service (LUI) were impacted, and are now failing to report.
 

  • When admins access the License Usage Insights service in Citrix Cloud, an impacted license server will show as "not reporting" in the server-status view.

 

  • When the admin launches the License Administration Console on the Citrix License Server, they may find the following error displayed, “Previous upload to Citrix.com failed with code 7".


 

  • Additionally, if the admin were to open the ‘Usage’ XML file under C:\Program Files (x86)\Citrix\Licensing\LS\Resources, they may find the following error message:  CTX_UPLOAD_ERROR_NETWORK_SSL_OPEN

Resolution

  1. Download the latest version of the Citrix License Server, refer to https://www.citrix.com/downloads/licensing/license-server/  
  2. After restarting the license server, it's expected to show as "Reporting" in the License Usage Insights Service server status view within 10 minutes

Problem Cause

To improve Security, Citrix now requires TLS 1.2 or newer for license server communication.  In March 2020, Citrix deprecated license server communication using TLS 1.0 which may result in a license server previously reporting to no longer report successfully.

 

Additional Information