Cloud Device Registration fails when using Active Directory + Token

Cloud Device Registration fails when using Active Directory + Token

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Article ID: CTX270650

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Updated On:

Description

When registering a device using OTP with Citrix Cloud, you might receive an error "user not found" after putting in username/password but before putting in a token.
If you are only using Active Directory without Token with Device Registration, there is no issue logging in.

Resolution

Check Active Directory user attributes for an affected user and ensure that the "mail" attribute is correct.

Problem Cause

Mail Attribute is required in order to send the email with Token for MFA.  If this attribute is missing or incorrect the login will fail.

Additional Information

https://docs.citrix.com/en-us/citrix-workspace/experience.html