Unable to federate domain in Multi-tenant CVAD service for Citrix Service Providers (CSP)

Unable to federate domain in Multi-tenant CVAD service for Citrix Service Providers (CSP)

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Article ID: CTX270526

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Updated On:

Description

An error occurred while attempting to federate a domain from the CSP’s Citrix Cloud account to a linked customer’s Citrix Cloud account.


Resolution

For Multi-tenant CVAD service for CSPs, the Citrix Cloud connector should be installed in the CSP’s Citrix Cloud account. The linked customer’s account should not have Citrix Cloud connectors installed.

1.      While federating the domain press "F12" and check the network logs to see if you are getting the error "The domain <domain name> already exists.”

2.      If you are seeing the above message, check if you have a connector installed in the linked customer’s Citrix Cloud account. If yes, please uninstall the connector on the customer’s account.

3.      If you are facing this issue even after uninstalling the connector, please contact Citrix Support as there may be cleanup steps that need to be taken in the backend.


Problem Cause

If the connector is not cleanly uninstalled from linked customer's account . This can create conflicts in domain information in Citrix cloud database which causes this issue .