Storefront 3.12 CU5 Error: Propagation failed on one or more Servers

Storefront 3.12 CU5 Error: Propagation failed on one or more Servers

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Article ID: CTX270458

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Updated On:

Description

PROBLEM:

When administrator launches Storefront Management Console and attempts to perform "Propagate Changes" on Servers , the process fails with the following error:

 

Error: Propagation failed on one or more Servers


 

Event logs on Primary Server shows the following event:

 

Event ID 31 

 

An error has occurred during the all server configuration update process.

Citrix.DeliveryServices.ConfigurationReplication.Exceptions.ServerUpdateConfigurationException, Citrix.DeliveryServices.ConfigurationReplication, Version=3.12.0.0, Culture=neutral, PublicKeyToken=e8b77d454fa2a856

Could not find an X509Certificate2 certificate with the specified thumbprint.

RemoteEndpoint: net.tcp://fantailwillow02/Citrix/ConfigurationReplication

 

 

On the Secondary Server the following events are seen:

 

Event ID 19

 

Failed to get the end status of the sever configuration update.

System.ServiceModel.FaultException, System.ServiceModel, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089

Could not find an X509Certificate2 certificate with the specified thumbprint.

   at Citrix.DeliveryServices.ConfigurationReplication.WCF.ConfigurationReplication.EndUpdateConfiguration(IAsyncResult asyncResult)

 

AND Event ID 12 

 

Failure to notify of configuration update.

Citrix.DeliveryServices.ConfigurationReplication.Exceptions.ClusterMemberCertificateNotFound, Citrix.DeliveryServices.ConfigurationReplication, Version=3.12.0.0, Culture=neutral, PublicKeyToken=e8b77d454fa2a856

Could not find an X509Certificate2 certificate with the specified thumbprint.

CertificateThumbprint: XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX 

 

Resolution

STEPS RESOLVE:

  • Check the list of Certificates and its thumbprints on Primary and Secondary Servers. 
  • This operation can be done by launching mmc.exe console and adding the "Certificates" snap-in.
  • Select "My Computer" when adding the Certificates snap-in
  • Expand the left pane directory and review each certificate in this list until the thumbprint is found. See example below of the mmc.exe console showing a list of certificates

 

  • Once the certificate with the thumbprint mentioned in the event viewer is found. Proceed to Export this certificate over to the Servers which are missing such file.
  • To Export certificate simply select the desired certificate from the list. Then right-click and select the option "Export". See image below as reference.



 

  • When certificate is added to those Storefront servers that were missing certificate, proceed to "Propagate Changes" using the Primary Server.
  • Verify propagation completed successfully on all servers part of the group.

 


    Problem Cause

    REASON FOR PROBLEM:

    • As indicated in event logs collected on each Storefront server, a certificate was missing inside the certificate store of some of the Storefront Servers experiencing the behavior reported.