Outlook Search Indexing Fails on Windows Server 2019 VDA

Outlook Search Indexing Fails on Windows Server 2019 VDA

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Article ID: CTX270433

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Updated On:

Description

When setting up a Windows Server 2019 virtual machine with Multi session VDA 1912, Outlook Search Indexing is not function properly.  In this scenario, User Profile Management functions as expected, and the OutlookOST and OutlookSearchIndex VHDX disks are properly mounted when user signed in.

However, search index roaming is not successful and a warning event is logged in the event log on Search with the message:

The update for the index cannot be started because the specified content sources were not configured for updates. Add at least one content source" 

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Set the following registry value if not present or already set to 0 [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search] "EnablePerUserCatalog"=dword:00000000

Problem Cause

This is caused by an earlier issue which was addressed in VDA 1912, but requires an additional registry value in Windows.