Citrix App Layering - Error while trying to import layers

Citrix App Layering - Error while trying to import layers

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Article ID: CTX270310

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Updated On:

Description

While trying to import layers, App Layering console displays an error: "An unexpected exception occurred. If this problem continues, contact Technical Support and provide them with the details of this exception".
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Looking at the ELM Web logs, we might see the below errors: 
 

ERROR [2832]    HandlerHelper: Unhandled System Error while processing 'Query' 'ImportableRevisionsQuery'

System.Threading.ThreadAbortException

 at <0x00000 + 0x00000> <unknown method>

 at (wrapper remoting-invoke) Unidesk.Ma.Core.Contract.IMaFileShareBaseService:QueryPortableVersionDetails (Unidesk.Ma.Core.Contract.Queries.PortableRevisionDetailsQuery)

 at MaFileShareService.QueryPortableVersionDetails (Unidesk.Ma.Core.Contract.Queries.PortableRevisionDetailsQuery ) [0x00006] in <c95541a62bf14d94b006de7142aab25b>:0 

2020-02-16 07:02:26,689 ERROR [2832]    HandlerHelper: Title: System Error Message: An unexpected system error occurred. Retry the operation or contact technical support. Details: Exception Message: ThreadAbortException Exception Details:

Resolution

Create a new folder in the root level of the share and try to see if you can point that for the import operation. There is no recursive limit. We enumerate recursively every file in the path we are given looking at *.laypkg files.

Problem Cause

It is possible if we are given a root directory with thousands of files under it that the call will timeout. Hence verify if it has a number of folders and sub-folders in the ELM share.

Issue/Introduction

While trying to import layers, App Layering console displays an error: "An unexpected exception occurred. If this problem continues, contact Technical Support and provide them with the details of this exception".