When user reconnect to a session, Outlook become stops for a while

When user reconnect to a session, Outlook become stops for a while

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Article ID: CTX269654

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Updated On:

Description

When user reconnect to a session, Outlook get high load (high CPU consume) and cannot operate Outlook for a while. This happens when user adds 25 ~ 30 people's schedule in Outlook and disconnect the session with the schedule screen displayed.

Resolution

Though this is Outlook issue. As a workaround:

1. Decrease the number of people's schedule to show.
2. Do not leave Outlook at the schedule screen while disconnecting the session.


Problem Cause

When Outlook receives global change message, such as, WM_DISPLAYCHANGE or WM_SYSCOLORCHANGE ( or maybe WM_WININICHANGE, WM_TIMECHANGE, WM_SETTINGCHANG as well ), Outlook needs to initialize display state and it will result in complex calculation and leads to high CPU consume.