App-v applications are not getting cached after starting XenApp Server

App-v applications are not getting cached after starting XenApp Server

book

Article ID: CTX269649

calendar_today

Updated On:

Description

In version 1909 applications are no longer pre-cached. For applications without isolation group, the application is started. 
For application with isolation group, the isolation group is not loaded and as a result the application cannot be started. If the Broker Agent on VDA is restarted then the applications are loaded correctly.  

Note:- In the previous version (1903) applications are pre-cached in the folder used for App-v Cache and the applications are immediately available for end users. 

Resolution

Our Engineering team will consider to include the feature to check if App-v services is running or not  in the next releases.

Perform the following workaround to resolve the issue: 

Workaround
  1. Restart the Broker Agent  Services
  2. Delay the Start of  Broker Agent  Services

Problem Cause

Broker Agent Services doesn't check if App-v Services is Started or not