Catalog creation fails in AWS when using Citrix MCS

Catalog creation fails in AWS when using Citrix MCS

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Article ID: CTX269405

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Description

You see the below error on Studio :

Exception: Citrix.Console.Models.Exceptions.ProvisioningTaskException A volume service instance could not be launched in your cloud connection. In Studio, select Hosting in the left pane and then select the cloud connection. Click Test Connection in the Actions pane. The test results should provide additional information. at Citrix.Console.PowerShellSdk.ProvisioningSchemeService.BackgroundTasks.ProvisioningSchemeTask.CheckForTerminatingError(SdkProvisioningSchemeAction sdkProvisioningSchemeAction) at Citrix.Console.PowerShellSdk.ProvisioningSchemeService.BackgroundTasks.ProvisioningSchemeTask.WaitForProvisioningSchemeActionCompletion(Guid taskId, Action`1 actionResultsObtained) at Citrix.Console.PowerShellSdk.ProvisioningSchemeService.BackgroundTasks.ProvisioningSchemeCreationTask.StartProvisioningAction() at Citrix.Console.PowerShellSdk.ProvisioningSchemeService.BackgroundTasks.ProvisioningSchemeCreationTask.RunTask() at Citrix.Console.PowerShellSdk.BackgroundTaskService.BackgroundTask.Task.Run() DesktopStudio_ErrorId : ProvisioningTaskError ErrorCategory : NotSpecified ErrorID : NoDiskContentTransferService TaskErrorInformation : Terminated InternalErrorMessage : No facility available for disk upload.


Behaviour on the AWS instance console 

You see the Preparation VM created and stopped 
You see an XD temp instance created and started 
It waited for almost 20 minutes before terminating and catalog creation process fails 

AWS cloud Trail logs 

You will see S3 bucket created by the AWS IAM user .
After this nothing much will be happening in the logs .

XD Temp Logs

If you select Xd temp VM and go to  Action-->Instance Settings-->Get system logs , you will see its trying to connect to S3 Bucket URL and just sitting there .

Note :If you are not seeing the URL being resolved to the IP , please check the DNS settings .

 

Resolution

How to check if the XD-temp VM has the Internet Connectivity to connect to the S3 bucket URLs 

Easiest Method is to create a VM instance in the same subnet as the XD temp getting created and attach the Same Security group which Xd-temp has and try to connect to the S3 bucket IPs or URL or browse the internet . If you have this issue , it will not connect .

Outbound traffic to 443 should be allowed from the Security group attached to the Xdtemp VM .

You can also check where the XD-temp is trying to connect by going to Action-->Instance Settings-->Get System Logs .
This will tell you the IP and the URL it is trying to connect .

Once you get the above info , try connecting to the same IPs and URL from the instance that you created for testing on the same subnet and security group as Xd-temp .

 

Problem Cause

XD-temp VM created will need access to S3 bucket URLs , either it should have internet connectivity or it should have IPs to S3 bucket white listed in Security Groups attached to the VM .