HDX sessions with CWA for HTML5 have a noticeable delay when launching.

HDX sessions with CWA for HTML5 have a noticeable delay when launching.

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Article ID: CTX267039

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Updated On:

Description

Launching a HDX session with the CWA for HTML5 client shows a delay of several seconds.
Issue is only seen on client machines with no internet access.
Issue only seen with latest HTML5 client - probably version 1909 onwards.

Browser logs show that a connection attempt to googletagmanager.com.
On internal workstations without internet access this results in a long delay of about 30 seconds before the connection attempt times out.
 

Resolution

For Version 2007 and later.

Administrators are allowed to block CEIP through the configuration.js file. This configuration takes precedence over the configuration made through the graphical user interface and CEIP data is not sent to Citrix.

  • Open the configuration.js file located in "C:\Program Files\Citrix\Receiver StoreFront\HTML5Client", add the connectionEnabled attribute, and set the attribute to false under analytics section: 

'analytics':{
'connectionEnabled':false, }



For Version prior to 2007 use one of the below workaround

1. Use a browser extension to prevent access to googletagmanager.com . So the load error condition would hit in the code immediately than waiting for a timeout.

2. On clients which don't have internet access set up a Windows Firewall rule blocking all outgoing traffic to the internet (this is a pre defined selection option) . This will instantly prevent  the connection attempt , which leads to more or less a zero delay.

     


    Problem Cause

    Change in CWA HTML5 Client.