Audio volume control now working within an ICA session on Windows Server 2016 VDAs

Audio volume control now working within an ICA session on Windows Server 2016 VDAs

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Article ID: CTX265700

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Updated On:

Description

Please consider below symptom:

  • While accessing the published Desktop session of a Windows Server 2016, the Audio Volume control bar as shown below doesn't appear with in the ICA session:

 
  • The same is functional in RDP and Console access.
  • As a work around, the volume can be controlled from the volume mixed as shown below:
  • ​​​​​​​The issue is also temporarily fixed once you add "ALL APPLICATIONS PACKAGES" to permissions on the below registry:
HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\citrix\Audio

Above change is reverted, when the Citrix Audio Redirection Service is restarted.
 

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

This issue has been addressed in Citrix Virtual apps and desktops 1912 LTSR.

Problem Cause

This is caused because the Citrix Audio Redirection service recreates the permissions of the above mentioned registry key at the startup.