book
Article ID: CTX263686
calendar_today
Updated On:
Description
This article is intended for Citrix administrators and technical teams only.
Non-admin users must contact their company’s Help Desk/IT support team and can refer to CTX297149 for more information.
When trying to autoupdate Workspace App for Mac from 19.10/19.10.1 to 19.10.2 and above you will receive the following error:

Resolution
Download and manually install the latest Workspace App for Mac release:
19.10.2 and above
Problem Cause
Due to a change in the API behavior introduced in the Catalina release with Apple's Notarization and XCode 10. Apple has changed the behavior for the APIs that are used to elevate privileges in which the upgrade helper application fails to launch. This will no longer occur once on the 19.10.2 release and above.