You receive an error: "No tenant identifying information found in either the request or implied by any provided credentials" when integrated with Intune and Secure Hub is in use.
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Article ID: CTX262036
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Updated On:
Description
When enrolling in to Citrix Endpoint Management for MDM, if the deployment is integrated with Intune for MAM, you may experience the following error and behaviour.
Without Secure Hub installed (using Intune MAM only), then no problems are seen.
When Secure Hub is installed and enrolled for MDM with CEM, then inbound connections from managed apps to the Gateway fail with the following error recorded: "No tenant identifying information found in either the request or implied by any provided credentials"
Resolution
Run the 'CreateScript' on NetScaler again using known good 'Client Secret' details. When rebooted, the OAuth status should show as 'Complete', not 'MDMINFO' (or any other status) and the symptoms of the problem should be gone.
Problem Cause
NetScaler OAuth configuration is incorrect. Should be status 'COMPLETE', not 'MDMINFO'
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