Upgrading to Storefront 3.12 CU4 fails - MSI logs shows Citrix Protocol Transition service exception

Upgrading to Storefront 3.12 CU4 fails - MSI logs shows Citrix Protocol Transition service exception

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Article ID: CTX261925

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Updated On:

Description

When attempting to upgrade Storefront 3.12 LTSR to CU4 fails.

In the Install wizard the following message is displayed:



When checking the MSI Installer logs the following exception is found
NOTE: MSI logs are found in C:\Windows\Temp\Storefront\CitrixMsi-CitrixStoreFront-x64-201X.-xx-xx-xx.log 

Example:
In this example we can see there is an exception found while Storefront is being upgraded to CU4. The installer has found Citrix Protocol Transition Service and a problem was found. see Excerpt below:

Here, an attempt to upgrade Storefront 3.12 CU1 over to CU4 failed. The error was: An error occurred creating the configuration section handler for citrix.deliveryservices/protocolTransitionSettings: Could not load file or assembly 'Citrix.DeliveryServices.ProtocolTransition.Configuration, Version=3.8.0.0

This was caused by the Citrix Protocol Transition Service on the Storefront Server.

....
Calling custom action Citrix.DeliveryServices.InstallControllerCustomAction!Citrix.DeliveryServices.InstallControllerCustomAction.CustomActions.SnapshotConfiguration
Begin SnapshotConfiguration
Creating version snapshot for version '3.12.1000.1'.
Loading backup history configuration
Loading backup configuration from: 'C:\ProgramData\Citrix\Storefront Install\3.8.0.44'
No snapshot exists for version '3.12.1000.1', create one now.
An error occurred creating the snapshot: 'System.Configuration.ConfigurationErrorsException: An error occurred creating the configuration section handler for citrix.deliveryservices/protocolTransitionSettings: Could not load file or assembly 'Citrix.DeliveryServices.ProtocolTransition.Configuration, Version=3.8.0.0, Culture=neutral, PublicKeyToken=e8b77xxxxxxxx' or one of its dependencies. The system cannot find the file specified. (C:\Program Files\Citrix\Receiver StoreFront\Services\ProtocolTransitionService\Citrix.DeliveryServices.ProtocolTransition.ServiceHost.exe.config line 9) ---> System.IO.FileNotFoundException: Could not load file or assembly 'Citrix.DeliveryServices.ProtocolTransition.Configuration, Version=3.8.0.0, Culture=neutral, PublicKeyToken=e8b77xxxxxxxxxx' or one of its dependencies. The system cannot find the file specified.

 

Resolution

To remedy this problem the following steps will need to be performed on the Storefront Server where the CU4 is going to be installed.
  • Before any actions are performed on the Storefront Server a proper VM snapshot will need to be taken. 
  • Open the Storefront Management Console
  • Go to the Store Node
  • check the Store > Configure Store Settings > Kerberos Authentication > and check if it is enabled or disabled. See image below:
  • NOTE: if Storefront environment has multiple stores, each store will need to be checked
  • Once it has been validated that Kerberos Authentication is DISABLED we need to check the Windows Service.
  • To determine if the Citrix Protocol Transition Service is actually being used on the Server
  • Go to Windows Server windows icon > type services.msc
  • The Windows Services console is launched
  • Check if Citrix Protocol Transition Service is running or Stopped (In the image below ) This shows such service is in a stopped state and also confirms it is not actively being used by Storefront.
  • Citrix Protocol Transition Service needs to be removed from Storefront (See steps on how to remove Service in the next section below)
  • Once the Service has been removed and Server rebooted, administrator can proceed to perform Storefront CU4 upgrade
  • Reboot Server when upgrade finishes
  • Validate environment was upgraded successfully.

STEPS TO REMOVE CITRIX PROTOCOL TRANSITION SERVICE

1. Start PowerShell as admin.
2. Run asnp citrix*
3. Remove-DSProtocolTransitionService
4. Close PowerShell
5. check Windows Services and ensure Citrix Protocol transition service is removed
6. delete C:\ProgramFiles\Citrix\Receiver Storefront\Services\Protocol Transition folder
7. Reboot server



 

Problem Cause

Citrix Protocol Transition Service might had been enabled on the environment in the past. Additionally, it might have been present on a previous Storefront build that was installed on that Server. The service remain on the server but was actually in a STOP state.