When closing and re-opening Workspace on IOS, refreshing or launching apps causes failure.

When closing and re-opening Workspace on IOS, refreshing or launching apps causes failure.

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Article ID: CTX261785

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Updated On:

Description

After IOS has enumerated and/or launched apps through Storefront via Netscaler Gateway, and the Workspace app is closed but not logged out, when re-opening Workspace you get failure when refreshing apps or launching new ones.
Error message seen if clicking an app after re-opening workspace - “CAMAuthManErrorCodeProtocol”.
Error message seen if refreshing apps after re-opening workspace - "There was problem updating current app list".
Issue is not present on Windows, MAC, or Android.

Resolution

Change logon type on Storefront gateway config to Domain or Domain + token, whichever is appropriate.

Problem Cause

On Storefront, the login type for Netscaler gateway is wrong.