Custom Domain User Groups Are Not Enumerating Applications in citrix Cloud
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Article ID: CTX259070
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Updated On:
Description
When using a Custom Security Group Application enumeration doesn't occurs.
When using 'Domain Users' or the individual user applications will enumerate without an issue on citrix Workspace.
Resolution
- The Cloud Connector's AD Agent service (which is the service that is interacting with AD) should be running as Network Service.
- The Cloud Connector queries AD as the computer account, need to ensure that the computer account / 'Authenticated Users' has access to read and list all containers and objects they intend to use with Citrix Cloud.
Grant read access to cloud connector machine Account on :
- Users OU in AD
- Domain Admin Group
- Ensure that the "Authenticated user" has read permissions correctly defined on Domain level under special Access .
The failure in enumeration could depend on what object the connector account is unable to read , so all of the above or just one permission could fix the issue .
Problem Cause
Restrictions or stricter access polices on AD in certain environments .
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