Users unable to authenticate via NetScaler

Users unable to authenticate via NetScaler

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Article ID: CTX258324

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Updated On:

Description

Issues in launching Linux VDAs via Gateway. But this works fine internally
The following error was observed in the Citrix Receiver:

"Unable to launch your application. Contact your help desk with the following information:
Cannot connect to the Citrix XenApp server. The Citrix SSL server you have selected is not accepting connections"



 

Resolution

SSO Name attribute was set to 'userPrincipalName' instead of 'samAccountName', and is what sent from Netscaler to the “Backend”.
On correction, the setup started working

Problem Cause

SSO Name attribute of the LDAP authentication action on NetScaler was set incorrectly.