NetScaler GUI displays "Session is invalid. Please login again." as a result of System clock being out of sync
book
Article ID: CTX256782
calendar_today
Updated On:
Description
- Despite using valid login credentials logging into the NetScaler GUI fails with the following error:
"Session is invalid. Please login again." as a result of System clock being out of sync"
- Shell command "date" returns an incorrect date/time
NetScaler-Shell# date
Fri Jan 11 11:23:31 BST 2116
NetScaler-Shell#
- NTP status shows "x" next to the NTP server(s) and a large "offset" value, this means that the connection to the NTP server(s) is lost
NetScaler-CLI> show ntp status
remote refid st t when poll reach delay offset jitter
==============================================================================
x10.144.100.20 .GPS. 1 u 39 64 377 9.058 1244664 93.985
x192.27.86.212 .GPS. 1 u 202 64 70 0.281 53773.0 246.158
Done
- Platform logs show the wrong date/time
NetScaler-Shell# tail -f /var/log/ns.log
Feb 18 00:37:44 <local0.info> 192.127.95.36 01/11/1980:18:09:28 GMT NetScaler 0-PPE-10 : API CMD_EXECUTED 6471712 0 : User nsroot - Remote_ip 10.144.144.136 - Command "show ns version" - Status "Success"
Resolution
- Enable NTP sync and check that the NTP drift and system date/time are now correct/as expected:
NetScaler-CLI> enable ntp sync
Done
NetScaler-CLI> show ntp status
remote refid st t when poll reach delay offset jitter
==============================================================================
*10.144.100.20 .GPS. 1 u 1 64 1 9.424 0.769 0.001
192.27.86.212 .STEP. 16 u - 64 0 0.000 0.000 0.001
Done
NetScaler-Shell# date
Fri Jun 21 15:23:31 BST 2019
NetScaler-Shell#
Problem Cause
Losing connectivity to the NTP server(s) can cause this behaviour
Was this article helpful?
thumb_up
Yes
thumb_down
No