Calls Fail with Inaccessible Edge Servers

Calls Fail with Inaccessible Edge Servers

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Article ID: CTX253897

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Updated On:

Description

Remote connectivity with RTOP requires Edge servers to be deployed and reachable from remote endpoints. A customer may not have deployed Edge servers on the internet to allow remote RTP/STUN/TURN, but already have users that need Skype for Business calling outside the network. If these users have RTME installed on their endpoints, most calls would fail with Edge servers being inaccessible.
 

Resolution

Edge Fallback Detection allows customers to use RTOP in Fallback mode when their endpoint cannot reach an Edge Server. This is an optional feature that will only run if the proper registry keys are set, which are described below. Edge connectivity checks will be performed on RTME startup. RTME will go into fallback mode if the edge server is configured and inaccessible from the remote endpoint.
 
How to enable feature
Go to registry location: [HKEY_CURRENT_USER\Software\Citrix\HDXRTConnector]
The registry key EdgeFallbackEnabled should be set to 1 as a DWORD (32-bit).
The registry key DisableFallback should be set to 0 as a DWORD (32-bit).

Checking Fallback mode enabled by Edge Fallback Detection
There is a new field that will show up in the About window of RTC. “Edge Server Inaccessible” will appear below “Citrix HDX RealTime Connector – Unoptimized”. The “Edge Server Inaccessible” reason will only appear when in Fallback mode because of the Edge Fallback Detection feature. A screenshot of the About window with “Edge Server Inaccessible” is shown below.
User-added image

Problem Cause

Support for Skype for Business calls when the Edge server is not reachable. In these cases, the Optimization Pack goes into fallback mode and audio and video processing occurs on the server.
 

Additional Information

Limitations
If a user tries making a call during the short time frame when edge server detection is ongoing, then that call will be blocked. The blocked call will popup a window with an error saying, ”Call was not completed or has ended”. The user will not be able to close this window by clicking the hang-up button. The user must use the close button in the top right corner of window to close the blocked call.