Workspace App iOS - After entering credentials receiving "Cannot Add account" message

Workspace App iOS - After entering credentials receiving "Cannot Add account" message

book

Article ID: CTX249944

calendar_today

Updated On:

Description

- On the graphical interface receiving "Cannot Add account" message


- On the logs receiving the following HTTP responses:

HTTP response. url: https://<netscalerFQDN>/AGServices/Discover. statusCode: 403.
Response HTTP body: Error: Not a privileged User

HTTP response. url: https://<netscalerFQDN>/Citrix/Roaming/Accounts. statusCode: 401
<title>401 - Unauthorized: Access is denied due to invalid credentials.</title>

Resolution

- In the StoreFront Server (or Servers if there are multiple), remove the following lines from the web.config file located at: c:\inetpub\wwwroot\Citrix\Roaming\web.config

          <trustedIssuers decipherId="xxxxxxxx-xxxxxxxxxxxx">
            <add id="xxxxxxxxx-xxxxxx-xxxxxxx" location="http://example.com/Citrix/Authentication/auth/v1/token"" verifyId="xxxxxxxx-xxxxxxxxx-xxxxxxxx" />  
          </trustedIssuers>

- Open a CMD prompt and run "iisreset" to restart the IIS Web Server Service.

Problem Cause

There is a trusted issuers compatibility problem in this versions.
Contact Support if you need more information.