"netScalerLoginFailure" SNMP trap recieved and log message appear in /var/log/ns.log on NetScaler when logging in using SSH Key based authentication

"netScalerLoginFailure" SNMP trap recieved and log message appear in /var/log/ns.log on NetScaler when logging in using SSH Key based authentication

book

Article ID: CTX249928

calendar_today

Updated On:

Description

When SSH Key based authentication is being used, each time the a user logs in and authentication is performed using the SSH key pair, the following symptoms maybe observed:

  • Following messages are seen in /var/log/ns.log
Mar 12 12:16:48 <local0.info> 10.10.10.10 03/12/2019:12:16:48 GMT NetScaler 0-PPE-2 : default AAA Message 15216765 0 : "rba authentication : user username response_len-183 cmdPolicyLen-175, partitionLen-0 PromptLen-8 timeout 805309968 authPolicyLen-0 authActionLen-0 ssh_pubkey_len-0"
Mar 12 12:16:48 <local0.info> 10.10.10.10 03/12/2019:12:16:48 GMT NetScaler 0-PPE-3 : default SNMP TRAP_SENT 14274904 0 : netScalerLoginFailure (nsUserName = "username", nsPartitionName = default)
  • The following SNMP Trap is sent out by NetScaler:
12:16:48.124104 IP 10.10.10.10.3000 > 10.10.10.11.162:  C="4snmp2nms" V2Trap(128)  .1.3.6.1.2.1.1.3.0=136126 .1.3.6.1.6.3.1.1.4.1.0=.1.3.6.1.4.1.5951.1.1.0.55 .1.3.6.1.4.1.5951.4.1.10.2.4.0="username" .1.3.6.1.4.1.5951.4.1.10.2.23.0=127.0.0.1 .1.3.6.1.4.1.5951.4.1.1.2.0=10.91.31.177
  • These messages will also appear in the NetScaler MAS (assuming that MAS is deployed and has been configured to recieve SNMP traps and syslog data from NetScaler)

Resolution

This is a cosmetic issue, Citrix are currently working on a solution.

Problem Cause

The root cause of this issue is in the platform software.

Issue/Introduction

"netScalerLoginFailure" SNMP trap recieved and log message appear in /var/log/ns.log on NetScaler when logging in using SSH Key based authentication