Exchange ActiveSync traffic via Citrix ADC fails for Android Devices
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Article ID: CTX247383
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Updated On:
Description
The exchange active sync traffic via Citrix ADC fails for Android devices. Tried on different Android devices including Samsung and LG. It works for IOS devices.
Since the client get an error at Authentication phase, tried modifying LDAP server traffic from Secure 636 to PlainText 389. Yet it did not resolve the issue.
Resolution
Enabling the SSO Should fix the issue.
> add tm sessionAction actsync_profile -SSO ON
How IOS devices works fine?
When the SSO is turned off the '401 Unauthorised' response from ADC will be sent to the client. IOS devices react properly for that response.
When it is turned on '401 Unauthorised' from backend server will be handled by Citrix ADC.
Problem Cause
SSO not enabled on the profile
> add tm sessionAction actsync_profile -ssoDomain local.lab -httpOnlyCookie NO
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