XMS : DEP Settings are not getting removed| Status - Pending Removal
book
Article ID: CTX246753
calendar_today
Updated On:
Description
While trying to remove the existing DEP config from the XMS sevrer console it stays on pending state:

The connectivity is fine between the XMS server and the DEP portal, by this time we have already removed the another MDM configuration from the DEP portal as its not been used.
It does not allow us to add the same DEP configuration, from the add option, as the configuration already exist. Gives an error:
Unexpected error at com.citrix.ios.bulkenrollment.handlers.impl.DepAccountHandlerImpl.createOrUpdate from createOrUpdate: could not execute statement
org.hibernate.exception.ConstraintViolationException: could not execute statement
Resolution
For On Prem XenMobile Server
- While the DEP status is set to pending removal on XMS, we have added a new MDM config in the Apple DEP portal.
- Moved all the devices associated with the new config
- Once it’s done, remove the original config from the Apple DEP portal
- Restarted the XMS Server
For CLOUD Customers:
- Check the un-enrolled DEP devices on CEM console under "Manage" section.
- The un-enrolled DEP devices should be displayed with grayed out "MDM" & "MAM" label, delete those devices and then restart server.
- The DEP account should be deleted automatically.
Problem Cause
The original config exists on the DEP portal, which keeps on trying to connect back to the XMS server and doesn't allow the config to be removed or re-added.
Was this article helpful?
thumb_up
Yes
thumb_down
No