TrolleyExpress.exe crashed when Workspace app (Receiver) was installed.

TrolleyExpress.exe crashed when Workspace app (Receiver) was installed.

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Article ID: CTX246453

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Updated On:

Description

This article is intended for Citrix administrators and technical teams only. Non-admin users must contact their company’s Help Desk/IT support team and can refer to CTX297149 for more information.


TrolleyExpress.exe crashed when Workspace app (Receiver) was installed.

Resolution

There are 3 workarounds. Choose one workaround.
  • Install ".Net Framework 4.X" or above.
  • Uninstall "Visual C++ Redistributable for Visual Studio 2015"
  • Rename the following "VCRUNTIME140.dll"  to something like "VCRUNTIME140.dll_" before the installation. After the installation, it must be renamed to the original "VCRUNTIME140.dll".
    • 32bit OS ... C:\Windows\System32\VCRUNTIME140.dll
    • 64bit OS ... C:\Windows\SysWOW64\VCRUNTIME140.dll

Problem Cause

The issue occurs on the client environment which matches the following all conditions.
  • Receiver 4.11 or above, including Workspace app
  • "Visual C++ Redistributable for Visual Studio 2015" has been installed.
  • ".Net Framework 4" or above has not been installed.