Endpoint Management 10.9.0.12 - Profile installation failed, MDM Payroll error

Endpoint Management 10.9.0.12 - Profile installation failed, MDM Payroll error

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Article ID: CTX245775

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Updated On:

Description

Unable to enroll DEP devices, failing while the 2nd profile installation with an error: "the new mdm payload doesn't match the old payload"

Resolution

  1. Get the correct .pfx file, re-upload it to the XMSserver and reboot it it.

  2. Now it should be in a proper chain.

  3. For the DEP devices which are not able to connect to the XMS server, need to full wipe them and enroll them again.

  4. After doing this, they will get enrolled without any error and now the users can remove both the profiles manually, and re-enroll the devices.


Problem Cause

Found that the SSL listener was not in a proper chain. Manual MDM profile removal under DEP configuration was blocked.