Cloud Workspace Users Unable to Authenticate

Cloud Workspace Users Unable to Authenticate

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Article ID: CTX241512

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Updated On:

Description

When a user attempts to log into their Cloud Workspace site they are not presented an error but are redirected back to the login site.

Resolution

Solution 1: 

Disable Cloud Site Aggregation by following the below: 

To disable an on-premises Site:

  1. From the Citrix Cloud menu, click Workspace Configuration and then click Sites
  2. On the Sites page, click the ellipsis button for the Site you want to disable.
  3. Click Disable. A confirmation message appears.
  4. Click Disable.

Solution 2:

Create a forest trust between the domains which have been added to the Cloud site. To verify the domains which are being enumerated follow the below steps:

1. From the Citrix Cloud management console, click the menu button and choose Identity and Access Management.
2. Choose Domains.

 

Problem Cause

Referenced: https://docs.citrix.com/en-us/citrix-cloud/workspaces/add-on-premises-site.html

Untrusted forests are not supported for Site aggregation. Although Citrix Cloud and Citrix Workspace support users from untrusted forests, these users are not able to use Citrix Workspace after an on-premises Site has been added through Site aggregation. Only users located in the forests that the Site trusts can log in and use Citrix Workspace

Issue/Introduction

When a user attempts to log into their Cloud Workspace site they are not presented an error but are redirected back to the login site.