MCS fails on AWS due to name resolution failure for S3 bucket

MCS fails on AWS due to name resolution failure for S3 bucket

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Article ID: CTX241341

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Updated On:

Description

When we are running the MCS process and it fails with generic error message.
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Below are the steps we observed happening when we create the catalogue.
 

  1. Preparation VM gets created.
  2. Preparation VM goes into stopped state.
  3. XenDesktopTemp gets created.
  4. We can see an object uploaded to S3 from DDC.
  5. XenDesktop Temp does not shuts down.
  6. After 30 minutes, exception is thrown and MCS process fails.

Resolution

Changed the DHCP option set for default VPC to point to AWS default DNS servers.
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Problem Cause

If default VPC is configured with custom DNS server, XenDesktop Temp cannot resolve the name for S3 URL then XenDesktop VM will never be able to initiate an HTTPS connection to S3 bucket. This will not work even if you provide the internal DNS server as primary and AWS as secondary or vice-versa.
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This is the default behaviour of a linux machine running on AWS.

Additional Information

https://support.citrix.com/article/CTX241160