1-16-2019 Citrix Cloud Connector Incident Management: Failed Connectivity Check
book
Article ID: CTX241284
calendar_today
Updated On:
Description
The Citrix Cloud connector is currently failing a connectivity check, resulting in Citrix Cloud administrators being notified and alerted.
There is no impact to end users or connector functionality at this time, despite the connectivity check failure and alert. This alert message can be ignored by administrators at this time while Citrix works towards resolution. The Connector download package can still be downloaded from the Citrix Cloud administrator UI, and new connectors can still be deployed with a command line workaround below.
Resolution
Impact & Workaround
- New Cloud Connectors will fail the connectivity check performed during install which will prevent installation from proceeding. A workaround is available by installing the connector from the command line using the /SkipConnectivityTest:true parameter. Using this workaround customers can install new connectors, and the connector will be fully functional.
To install a new connector while this issue is active, run this from the command line: .\cwcconnector.exe /skipconnectivitytest:true
Example of connectivity check failure alert appearing during connector install
- Existing Cloud Connectors will fail their regular connectivity checks and generate in-product notifications and warning status. Connectivity checks are executed automatically every hour, or on-demand via the administrative UI.
- At this time, Citrix has stopped the regular hourly health checks from running to avoid unnecessary alerting.
- In-product connector status may still reflect the results of the last executed health check. There is no workaround available to suppress the failed connectivity check status in the connector UI.

Example of connectivity check failure alert appearing in the Connector UI
Example of connectivity check failure notifications appearing in the Citrix Cloud administrator navigation UI
Example of connectivity check failure notifications appearing in the Citrix Cloud notifications UIHow it works:The connectivity check is performed to confirm the connector machine can access the storage URL hosting the connector download. The connectivity check reaches out to a storage URL to confirm the connector machine is able to contact and receive a response from that URL. The primary function of this check is to ensure network connectivity to the internet, and access to that specific URL. During this check, the connector is not targeting a specific file or download, but is confirming a specific response from that storage. The response the connectivity check receives from accessing that URL has changed recently, triggering the error shown and issue cited above.
Problem Cause
The Citrix Cloud connector is currently failing a connectivity check, resulting in Citrix Cloud administrators being notified and alerted.
There is no impact to end users or connector functionality at this time, despite the connectivity check failure and alert. This alert message can be ignored by administrators at this time while Citrix works towards resolution. The Connector download package can still be downloaded from the Citrix Cloud administrator UI, and new connectors can still be deployed with a command line workaround below.
Issue/Introduction
Summary of Incident 1/16/19 Handling CLoud Connector install failures and connectivity Check Issues
Additional Information
Our Commitment to Service, Reliability and PerformanceCitrix teams are continuously taking steps to prevent and mitigate future incidents. Citrix Cloud engineering teams are actively investing in architectural and operational items focused on high availability and service resiliency. As a reminder, status.cloud.com is where all outages and impacts to Citrix Cloud are communicated broadly to customers. Please reach out to Citrix Technical Support if you have any further questions.
Was this article helpful?
thumb_up
Yes
thumb_down
No