Citrix Licensing Manager Reports Error Code 400

Citrix Licensing Manager Reports Error Code 400

book

Article ID: CTX241261

calendar_today

Updated On:

Description

After upgrading licence server to 11.15.0.0 build 25000, Citrix Licensing Manager (https://localhost:8083 ) displays the error : For assistance, contact Citrix Customer Service and reference error code 400.

Environment

Citrix is not responsible for and does not endorse or accept any responsibility for the contents or your use of these third party Web sites. Citrix is providing these links to you only as a convenience, and the inclusion of any link does not imply endorsement by Citrix of the linked Web site. It is your responsibility to take precautions to ensure that whatever Web site you use is free of viruses or other harmful items.

Resolution

Modify the following:
LimitRequestFieldSize in the file C:\Program Files (x86)\Citrix\Licensing\WebServicesForLicensing\Apache\conf\httpd.conf

For additional guidance, you may refer to the Microsoft documentation referenced in this article. 
 

Problem Cause

If the HTTP header or packet size increases past the limits that are configured on the server, the server may reject the request and send an error message as the response.

Issue/Introduction

Citrix Error code 400 resolution may need modification of a file named httpd.conf

Additional Information

https://support.microsoft.com/en-ie/help/2020943/http-400-bad-request-request-header-too-long-response-to-http-request