VDAs Freeze and Users' Session Get Disconnected

VDAs Freeze and Users' Session Get Disconnected

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Article ID: CTX241136

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Updated On:

Description

After several days of being up and running, VDAs become unresponsive/frozen, show unregistered in Studio, and user sessions get disconnected. 

Resolution

When using the Machine Creation Services Storage Optimization or MCSIO feature in Citrix Virtual XenDesktop, make sure the temporary disk cache has been sized according to the workloads expected.
 

As a general rule, it is recommended that you size your temporary disk cache to at least disk free space plus memory page file.

Temporary cache disk = VM available disk space + VM page file.


If the disk cache runs out of space, the user’s session becomes unusable, and the system hangs or an error on a blue screen appears.

Note: It is not possible to change the cache values in a machine catalog after it is created. The catalog needs to be recreated.

Problem Cause

The temporary disk cache has run out of space.

Additional Information

Introducing MCS Storage Optimization - https://www.citrix.com/blogs/2016/08/03/introducing-mcs-storage-optimisation/
Reducing Shared Storage IO Over 90% with MCS Storage Optimization - https://www.citrix.com/blogs/2016/08/15/reducing-shared-storage-io-by-over-90-with-mcs-storage-optimization/
Considerations of Using MCS Storage Optimization - https://www.citrix.com/blogs/2016/09/12/considerations-of-using-mcs-storage-optimisation/