Unable to Access the Citrix Cloud Studio Portal - Error "Manage Page Could Not be Loaded."

Unable to Access the Citrix Cloud Studio Portal - Error "Manage Page Could Not be Loaded."

book

Article ID: CTX241130

calendar_today

Updated On:

Description

Unable to load the Manage page in the Citrix cloud studio. Message : Manage page could not be loaded.

Resolution

To resolve this issue:

  1. Clear the Browser cache and cookies.

  2. Relaunch the Browser.

  3. Try accessing the Studio again.

  4. Try incognito/Inprivate browsing mode 

  5. Try with a different admin account.

  6. Try from a different computer/Network.

  7. Check https://status.cloud.com/ for any outage being reported. 

If these steps do not help, contact Citrix Technical support for further troubleshooting. 


Problem Cause

Browser Cache and cookies.

Issue/Introduction

Users are unable to access Citrix Cloud Studio. The "Manage" page shows error "Could Not be Loaded" . All other options work as expected.