For Desktoplock client, VDI gets disconnected once launching XenApp app in current ICA session

For Desktoplock client, VDI gets disconnected once launching XenApp app in current ICA session

book

Article ID: CTX241084

calendar_today

Updated On:

Description

For Desktoplock client, even with Workspace Control Reconnect disabled, VDI still gets disconnected once launching XenApp app in current ICA session.

Resolution

Unselect "Application Prelaunch" for the application delivery group to resolve this issue.


Problem Cause

For the application delivery group, Application Prelaunch is selected. The issue logic goes like:

  1. User logon desktopLock client.

  2. VDI is auto-launched, meanwhile a XenApp session is pre-launched.

  3. In VDI, user logon Receiver or clicking App icon.

  4. Pre-launched XenApp session is disconnected and taken over by Receiver in VDI.

  5. DesktopLock will auto-logoff client machine.

  6. It caused VDI session being disconnect too.